BuddyDev

Search

Replies

  • Participant
    Level: Initiated
    Posts: 6
    Thomas Kamplain on #37478

    Hi Ravi!

    Thank you so much for looking into this. Yes, I was testing with an administrator account and the restriction was not working. I tried to test with a subscriber account and I can now see the restriction working. This is really confusing because I saw on the plugin’s settings page that I could restrict the Administrator role and I could also set a limit. If I may suggest, if the plugin is not supposed to restrict the Administrator role, the settings page should be changed so that it doesn’t allow the user to set a limit for the Administrator role. There should just be a note there that says these settings do not apply to administrators.

    Also, I encountered another problem but I was able to figure it out. I’ll just share it here for anyone who might encounter the same. If you are using BuddyBoss, there is a setting called “Group Access” where you can select which members should have access to create groups based on things like WordPress Role, Membership (we were using Paid Memberships Pro), etc. This setting can be found on BuddyBoss > Settings > Groups > Group Access. It looks like this setting was overriding any of the restrictions set using the plugin “Limit BuddyPress Groups Per User”. So if you are using both BuddyBoss and this plugin, I think you should disable the “Group Access” setting of BuddyBoss and just use this plugin to restrict who can create groups and how many groups each user role can create.

  • Participant
    Level: Initiated
    Posts: 6
    Thomas Kamplain on #36935

    Hi Brajesh! I have now updated to version 1.8.7 and the issue is now fixed. Thank you for the really quick help and resolution!

  • Participant
    Level: Initiated
    Posts: 6
    Thomas Kamplain on #36912
    This reply has been marked as private.
  • Participant
    Level: Initiated
    Posts: 6
    Thomas Kamplain on #36911

    That’s great, Brajesh! Thank you!

    On our main site, we are using Paid Memberships Pro and a custom code to handle the login redirect feature. We used to utilize the “Private Website” feature of BuddyBoss before and we also used that on our staging site to easier troubleshoot this problem with the Profile Visibility Manager. They follow the same approach though, they will append a “redirect_to” attribute to the login URL so that the user can get redirected to the referrer page after they have logged in. Can the fix/new release cover this as well? Or maybe, should I just adjust the priority of our custom code?

    I’ll share another video from our main site on a separate private reply.

  • Participant
    Level: Initiated
    Posts: 6
    Thomas Kamplain on #36878
    This reply has been marked as private.
  • Participant
    Level: Initiated
    Posts: 6
    Thomas Kamplain on #36877

    Hi Brajesh!

    Thanks for your reply! Yes, the activity belongs to a user who has marked their profile private. However, that user is me so I was expecting that I can still see my own post after I log in.

    Below are the steps to replicate the problem. I will also share a video recording of our site in a separate private reply to give you a better picture of the problem.

    1. Enable the “Private Website” setting of BuddyBoss
    2. Set the profile visibility of the user who will be making the post to “Only Me (private)”
    3. Post a new update on the news feed (activity feed)
    4. Using a separate account, write a reply to the post
    5. An email notification will be sent to the user notifying him that there was a reply to his own post
    6. Open the link on a browser session where no one is logged-in (incognito browser)
    7. A 404 error appears as I try to view the reply to my own post

    Is there a solution for this, so that I can still be directed to my own post after I login successfully?

Subscribe