BuddyDev

Search

[Resolved] Activity Auto Moderation

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #38655

    Hello,

    Please do let me know if the setting name “Delegate moderation capability to user roles” is enabled or not. If yes, What are the “Moderation Manager Roles”.

    You can find these settings under the Settings > Miscellaneous tab.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 14
    Fourth Frontier on #38662

    Hi Brajesh and Ravi,

    Thanks for the updates. We will wait for the compatibility update. Overall we loved the plugin , hoping this update will fix our issue . 🙂

    “Delegate moderation capability to user roles” is set as ‘No’.
    In ‘Moderation Manager Roles’ we have chosen ‘Administrator’.

    Should i change any of these ?

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #38694

    Hello,

    Thank you for the acknowledgment. I have tested this plugin with Youzify version 1.0.5 and BuddyPress version 7.3.0 and all works well. After login with the user with the contributor role, everything works will no in-moderation activity show to the contributor. Is it possible to temporarily share your staging admin credentials so that I can check what is going on on your end?.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 14
    Fourth Frontier on #38698
    This reply has been marked as private.
  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #38701

    Hello,

    Thank you for sharing the details. I have install and activated “User Switching” plugin temporarily. Then switch to rohan(contributor) and post an activity update with this user. After posting switch to another user Younus(contributor) and found that moderated activity of rohan is not showing to Younus and only viewable to admin only.

    Please give it a shot by posting an activity with a user with role other than administrator weather this user in-moderation activity is viewing to other users or not.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 14
    Fourth Frontier on #38702

    Hi,

    I just tried below steps right now:-

    – Changed role of user ‘Aparna’ to contributor and posted “trial as contributor”.
    – Now it is hidden for author (aparna) also.
    – It is visible for Admin with the ‘In moderation’ label.
    – Earlier it was visible for all including author. Now it is visible only for admin (not even author).

    I am unable to share screenshots ,else i would have attached the same . Is it possible to debug via zoom call or google meet for more clarity? Let me know.

    Reverting role of user Aparna to Admin so that you may check again .

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #38707

    Hello,

    Thank you for checking.

    – Changed role of user ‘Aparna’ to contributor and posted “trial as contributor”.
    – Now it is hidden for author (aparna) also.
    Is it the same user with a changed role to the author as an activity author?
    – Earlier it was visible for all including author. Now it is visible only for admin (not even author).
    The Activity post will be visible to only admin, activity author, and allowed moderator roles if any. Activity will not be shown to other users with the same role.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 14
    Fourth Frontier on #38708

    Hi ,

    The problem is that now it is not visible to activity author.

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #38711

    Hello,

    It seems a configuration issue as you have enabled auto-moderation setting for activity. Whenever a user post activity is automatically coming into the moderation queue due to this activity author not able to see this. But if you set the setting with the name “Hide reported content from poster” to no. Only then activity author can his/her activity.

    I have set this setting to no. Please give it a shot now.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 14
    Fourth Frontier on #38712

    Hi Ravi,

    Thanks . Its all working good and as expected now 🙂 .

    Just for my understanding, what are the changes you did to fix these ? I listed two below , is there any thing else , any setting or fix you added from your end ?

    – fix 1 – But if you set the setting with the name “Hide reported content from poster” to no.
    – fix 2 – “User Switching” plugin seemed to have helped with not showing “in moderation” label to contributors. before that plugin this functionality wasn’t working , but after installing this plugin it got resolved. Was it the plugin or did you change/add a compatibility

You must be logged in to reply to this topic.

This topic is: resolved