BuddyDev

Search

Issues with BP Deactivate Account

  • Participant
    Level: Enlightened
    Posts: 41
    Khalid Mohamed on #40786

    Dear BuddyDev Support Team;

    We just purchased “BP Deactivate Account”, but faced with 2 issues while testing. FYI, we are using BuddyBoss;

    1- The Link redirection functionality doesn’t work. After deactivation, the setting page is redirected to the User Profile (if we aren’t forcing the user to log out) and to the logged out homepge (if we are forcing the user to log out)

    2- After deactivating account, the message showing the account is deactivated still exists and only removed if the page is refreshed.

    Regards
    Khalid

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #40790

    Hi Khalid,
    Thank you for purchasing the plugin.

    I am sorry for the inconvenience. I am checking it and will be getting back to you in couple of hours.

    Regards
    Brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #40793

    Hi Khalid,
    Thank you for the patience. I have checked it now.

    1. The redirection is working as expected. We are only redirecting if you select logout. If you do not, we redirect to user’s default profile landing page.

    2. The message ”
    Your account is inactive. Please activate it to use all site functionality.” will appear all the time on their profile. It allows the users to know that their account is inactive and they must activate to to participate.

    Do you want some change in these behaviour?

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 41
    Khalid Mohamed on #40794

    Hi Brajesh;

    Regarding the message, sorry, I meant it still exists after the account is activated. It’s supposed to change to something like “Your account is active.”

    Regarding redirection, we tested it and it didn’t work even when selecting Logout User. I need you to log into our testing website, please, using the admin credentials I’ll send in the next message and check the below 3 issues. FYI, we are using ARmember membership plugin (It’s designed to work with Buddypress and BuddyBoss.

    1- Redirection doesn’t work
    2- Users with inactive account have issues on logging in whether we are allowing them to login or preventing them with a message.
    3- If a user is opening “Account Status” setting page and logs out, 404 error page is shown after logging out.

    Kind Regards
    Khalid

  • Participant
    Level: Enlightened
    Posts: 41
    Khalid Mohamed on #40795
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #40827

    Hi Khalid,
    Please disable ARMember temporarily and test it. My assumption is that plugin is adding extra restrictions or redirects leading to the issue.

    PS:- Do you have a staging site(let us avoid testing on the live site) where I can try these?

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 41
    Khalid Mohamed on #40918

    Hi Brajesh;

    Sorry for my late reply.

    You can use the site we sent for testing. It’s not live.
    We deactivated ARmember and still the redirection doesn’t work.
    Please, check

    Regards
    Khalid

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #40922

    Hi Khalid,
    Thank you.

    I will check and get back to you b y Monday.

    Regards
    Brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #40953

    Hi Khalid,
    I have deactivated all the plugins and set the redrect to your site’s cart page. It is working fine on redirection.

    The redirect is not working for external sites as we are using bp_core_redirect which uses wp_safe_redirect and that limits which domains are safe for redirection.

    Can you please check?

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 41
    Khalid Mohamed on #40963

    Hi Brajesh;

    Thank you for your efforts. I also checked and found that all the 3 issues are due to the conflict with ARmember.

    We can live without redirection, what about the other two conflicts (signing in for deactivated accounts and 404 when logging out from Account Status page)? Is there a solution?

    Regards
    Khalid

You must be logged in to reply to this topic.

This topic is: not resolved