BuddyDev

Search

[Resolved] Language files not "taking"

  • Keymaster
    (BuddyDev Team)
    Posts: 22166
    Brajesh Singh on #1086

    Hi Jan,
    Thank you for updating. You are right the old po file was not updated. Will do an update and push today.

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 104
    Jan Anderson on #1100

    Cool,

    We will need a pot file to update with correct strings right?
    best
    j

  • Keymaster
    (BuddyDev Team)
    Posts: 22166
    Brajesh Singh on #1102

    Yes, you are right. If you have poedit, you can do it yourself by simply updating path in settings and updating the catalog.
    I am holding the update to provide fix for one more issue I have noticed.

  • Participant
    Level: Enlightened
    Posts: 104
    Jan Anderson on #1306

    D-loaded the latest build today from this site.
    It is still called mediapress-master FYI.
    If there was supposed to be a .pot file in there I can’t find it?
    No worries, but when you have a sec?
    best
    j

  • Keymaster
    (BuddyDev Team)
    Posts: 22166
    Brajesh Singh on #1310

    Hi Jan,
    The problem is current downloads are served from github and that’s why you get mediapress-master and not mediapress. Once we tag and provide downloads from BuddyDev/wporg it will be mediapress.

    I just pushed the updated languages file 2 minutes ago, It has around 64 new strings.

    For now, after you download, please extraxt the zip file and you will get “mediapress-master” folder. Rename that folder to “mediapress”.

    After that if you use ftp, you can directly upload it. If you don’t use ftp and want to upload via WordPress plugin installer, please zip that folder and upload. That will work.

  • Participant
    Level: Enlightened
    Posts: 104
    Jan Anderson on #1320

    Thanx Keymaster Guru, sounds good

    Still no .pot file though.
    I don’t think I can update my work in progress language file from a new .po file? Right?
    thanx
    again
    j

  • Participant
    Level: Enlightened
    Posts: 104
    Jan Anderson on #1321

    Figured it out. Did not know one can update from source files in PO edit.
    You learn something every day..
    Some strings are still not translating properly though…
    Any things I should look for?

    best
    Jan

    • This reply was modified 7 years, 1 month ago by Jan Anderson.
  • Participant
    Level: Enlightened
    Posts: 104
    Jan Anderson on #1323

    Do strings and lines translate correctly if I update from source, using a folder of the latest download from here?
    Or do we still need a .pot file to get it right? I notice different paths in the original US .po file and my new translation.
    Probably should be the same?

    thanx
    j

    • This reply was modified 7 years, 1 month ago by Jan Anderson.
  • Keymaster
    (BuddyDev Team)
    Posts: 22166
    Brajesh Singh on #1326

    Hi,
    Yes, you can update from sources and things will be fine. If you do that, please make sure to update your source path. If you are using poedit , it is under Catalog->properties->source paths section.

    PS: I have been calling the .po file as pot. sorry about the confusion.

  • Participant
    Level: Enlightened
    Posts: 104
    Jan Anderson on #1328

    No worries.

    Most of ny translations are now taking, but not all.
    Sorry about this, have not done this before in PO edit.
    Are you sure everything is fine and dandy in the pot file?
    As an example of a string that is not taking below if you have time to check it?
    Not sure what to do…safer with .pot file?

    best
    Jan

    “There are no galleries available!”

    In my swedish .po file around here:
    #: templates/mediapress/default/gallery/loop-gallery.php:58
    #: templates/mediapress/default/widgets/gallery-list.php:63
    msgid “There are no galleries available!”
    msgstr “Inga gallerier här än!”

The topic ‘ [Resolved] Language files not "taking"’ is closed to new replies.

This topic is: resolved