BuddyDev

Search

[Resolved] MediaPress Local Transcoder

  • Participant
    Level: Initiated
    Posts: 14
    David Dietz on #40857

    Hi there! I’ve just purchased support for the MediaPress Local Transcoder. Specifically, I need assistance getting the ffmpeg encoder functioning on my server. I have a VPS server running WHM/cPanel on Linux. Please advise as to next steps. Thanks!

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #40865

    Hi David,
    Thank you for purchasing our support package for it.

    1. Do you have FFMPEG installed or do you need help installing it and configuring both?

    Please let me know and I will assist.
    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 14
    David Dietz on #40872

    I followed the instructions here (https://www.milesweb.com/hosting-faqs/install-ffmpeg-whm-cpanel-server/?__cf_chl_captcha_tk__=pmd_I0hUnhcRiDL5fx2SGKn8vgqSx64bJYLyh2lw7ypHTnQ-1633640308-0-gqNtZGzNA1CjcnBszQmR), but the MediaPress Local Transcoder plugin doesn’t seem to acknowledge that it was installed on the server

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #40875

    Hi David,
    Thank you.

    Please run this command in the terminal

    
    which ffmpeg 2>/dev/null
    

    and let me know the output.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 14
    David Dietz on #40876

    /bin/ffmpeg

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #40877

    Thank you.
    Just one more command.

    Does it work

    
    ffmpeg -version
    

    and what is the output. Is it some version information or error?

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 14
    David Dietz on #40880

    Here’s the output for that:

    ffmpeg version 2.8.15 Copyright (c) 2000-2018 the FFmpeg developers
    built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-36)
    configuration: –prefix=/usr –bindir=/usr/bin –datadir=/usr/share/ffmpeg –incdir=/usr/include/ffmpeg –libdir=/usr/lib64 –mandir=/usr/share/man –arch=x86_64 –optflags=’-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong –param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic’ –extra-ldflags=’-Wl,-z,relro ‘ –enable-libopencore-amrnb –enable-libopencore-amrwb –enable-libvo-amrwbenc –enable-version3 –enable-bzlib –disable-crystalhd –enable-gnutls –enable-ladspa –enable-libass –enable-libcdio –enable-libdc1394 –enable-libfdk-aac –enable-nonfree –disable-indev=jack –enable-libfreetype –enable-libgsm –enable-libmp3lame –enable-openal –enable-libopenjpeg –enable-libopus –enable-libpulse –enable-libschroedinger –enable-libsoxr –enable-libspeex –enable-libtheora –enable-libvorbis –enable-libv4l2 –enable-libx264 –enable-libx265 –enable-libxvid –enable-x11grab –enable-avfilter –enable-avresample –enable-postproc –enable-pthreads –disable-static –enable-shared –enable-gpl –disable-debug –disable-stripping –shlibdir=/usr/lib64 –enable-runtime-cpudetect
    libavutil 54. 31.100 / 54. 31.100
    libavcodec 56. 60.100 / 56. 60.100
    libavformat 56. 40.101 / 56. 40.101
    libavdevice 56. 4.100 / 56. 4.100
    libavfilter 5. 40.101 / 5. 40.101
    libavresample 2. 1. 0 / 2. 1. 0
    libswscale 3. 1.101 / 3. 1.101
    libswresample 1. 2.101 / 1. 2.101
    libpostproc 53. 3.100 / 53. 3.100

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #40881

    Thank you.
    It confirms that you have installed FFMPEG successfully.

    Now, there are only 2 possibilities left.

    The shell_exec command is disabled or it is unable to execute the FFMPEG binary.

    Are you getting this notice in the admin

    “Transcoder needs FFMPEG. You don’t seem to have it installed.” or is it the conversion which is failing?

    If possible, Please enable debug log for WordPress and share it to me. That should point to the issue.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 14
    David Dietz on #40884

    Yes, I’m getting the “Transcoder needs FFMPEG. You don’t seem to have it installed.” error, but nothing is being thrown in the debug.log. The shell_exec is, I believe, enabled, as is the WordPress Debug.

  • Participant
    Level: Initiated
    Posts: 14
    David Dietz on #40885

    Update:
    I found an error log with the following info:

    [07-Oct-2021 22:14:36 UTC] PHP Warning: shell_exec() has been disabled for security reasons in /home/lindseylockett/public_html/community/wp-content/plugins/mpp-local-transcoder/src/core/class-mpplt-process.php on line 63

You must be logged in to reply to this topic.

This topic is: resolved