BuddyDev

Search

Mobile menu not clickable when MediaPress is enabled

  • Participant
    Level: Initiated
    Posts: 12
    Jean Christofferson on #17478

    I am using Divi 3.15 and BuddyPress 3.2.0. All is good except if I have MediaPress 1.4.2 enabled the mobile hamburger menu is not clickable. If I deactivate MediaPress it works. The site is going live in less than 8 hours and we need MediaPress for the profile upload cropping. Is there any workaround that I can use? Hosted WP Engine, PHP 77.0.30-0ubuntu0.16.04.1, WP 4.7, Divi 3.15 Memberium Version 2.62

  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #17479

    HI Jean,
    Pleas link me to the page where the issue is happening with a temporary account(subscriber) if feasible.

    It is most probably either a z-index issue of some JavaScript error that I can check quickly.

    I will be off for the day in 15 minutes or so, If you can share the details before that, I will be able to assist quickly.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    Jean Christofferson on #17480
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #17481

    Please disable BP Post from Anywhere plugin and let me know. It is throwing javascript error currently.

  • Participant
    Level: Initiated
    Posts: 12
    Jean Christofferson on #17482

    I can’t! Due do another issue with BuddyPress Nouveu we are using BP Post from anywhere to display the post forms. If we want to use Noeveau the activity stream and post do not load (bug identified 3 months ago but still not resolved.) Legacy works but the look is not acceptable to the client so we thought we had a good workaround using several plugins. I would welcome an alternative to BP Post from anywhere. I noticed it had problems and I had to insert to closing div tags after the short code. Any alternatives to BP Post from anywhere?

  • Participant
    Level: Initiated
    Posts: 12
    Jean Christofferson on #17483

    BP Post from anywhere is disabled now for testing but mobile menu still not clickable

  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #17484

    Thank you.

    I do see that. There is just one more issue remaining( You might be able to use the post anywhere plugin after we are done with this).

    Either the theme or a plugin is hardcoding and loading the MediaElement Player.

    MediaPress loads it one time and another time it is loaded by something else. In normal case, if people use wp_enqueue_script, this will not happen.

    Seems something is hardcoding it. Any idea?

  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #17485

    Could it be the infusion soft form plugin ? I am not sure but I see it is loaded just after the assets from that plugin. Do they have any option to audio/video and do they provide any option to disable it?

  • Participant
    Level: Initiated
    Posts: 12
    Jean Christofferson on #17486

    Infusionsoft plug in is now disabled – still no mobile menu.

  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #17487

    Please re enable it.

    It is not the plugin loading the second copy of Media Element JS Player. I have downloaded the plugin from wporg and tested it.

    Can you check your active plugins list and tell me if you think one of them is working with audio/video?

    There are two copies of the player loading and it is triggering a javscript error. That javascript error leads to your further issues. We need to find and fix the double loading and it will work.

    Please see the screenshots. The first copy is loaded on line 95
    https://i.imgur.com/nvPIs6f.png

    and another copy in the footer
    Around line 715
    https://i.imgur.com/nvPIs6f.png

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved