BuddyDev

Search

[Resolved] rtMedia Activity URL Preview plugin blocked by Community Builder theme?

  • Keymaster
    (BuddyDev Team)
    Posts: 19309
    Brajesh Singh on #37339

    Hi Janet,
    Thank you for the reply.
    Please share the activity preview plugin again and I will test and assist you.

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 76
    Janet B on #37342

    Upon looking at it more closely, it seems like the version had not changed from the one originally licensed, but perhaps it was removed and re-added and the mod to the .js file you requested was gone. So I put that mod back, although I noted it was on line 132 instead of line 131.

    I tried this both with and without updates to the rest of the plugins on the site, which were mostly BD updates.

    No URL previews…

  • Participant
    Level: Enlightened
    Posts: 76
    Janet B on #37345
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19309
    Brajesh Singh on #37355
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 76
    Janet B on #37361
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19309
    Brajesh Singh on #37388
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 76
    Janet B on #37737

    Hello,

    I have a new issue. The url link preview is working in the editor, but you cannot save the post. There are no obvious errors displayed and nothing is logged. Posts with a preview work fine. The problem occurs for both admin and other users.

    Please advise.

    Janet

  • Participant
    Level: Enlightened
    Posts: 76
    Janet B on #37738

    Error in post #37737 – Posts WITHOUT a preview work fine…

  • Keymaster
    (BuddyDev Team)
    Posts: 19309
    Brajesh Singh on #37768

    Hi Janet,
    Which editor you are referring to? Is is the activity post form? Was there any change recently?

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 76
    Janet B on #37787

    My apologies. An unfortunate and unimportant lack of precision on my part 😉 The “editor” is the text box that one enters an activity post.

    Sadly, there are constant changes. The number of plugins required to create a great site times the increasing rate of change in plugin revisions times and increased rate of change in the php world, wordpress core, etc., means that any WP site is a moving target, hour to hour, if not day to day. As I’m sure you can appreciate, it is difficult to thoroughly test every site every time a minor plugin update occurs. We try to be more careful with major updates.

    But I get burned occasionally. You may recall some initial conversation we had about problems with Activity Plus Reloaded? I have learned since that for some of us, that plugin broke when upgrading from php 7.3 to 7.4 (recent info for me). Trying to find out why is usually fruitless.

    Just since yesterday, there is a BuddyPress revision. Something like that would generally warrant more testing on our part, unless it was a minor bug fix release.

    That said, the site is built almost entirely from plugins written by BD or you personally. Recent plugin updates for this site were primarily some BD revisions, which are more stable than some. There are only a few other plugins. There have been no updates to the rtMedia plugin.

    But I’m not sure how or when it broke because it is easy to miss the error. We’ve focused primarily on failure to fetch and display the URL preview. I should have been more thorough. I don’t have a backup from three months ago, for instance, to compare to.

    However, what is happening now – and was happening when we corresponded on 3/29 (I just checked a backup) is that the URL preview is displayed and the post seems to be accepted. But if you go back to the group or activity stream later, there is nothing there.

    Without using the URL preview (just plain text) the posts work fine.

The topic ‘ [Resolved] rtMedia Activity URL Preview plugin blocked by Community Builder theme?’ is closed to new replies.

This topic is: resolved