BuddyDev

Search

Replies

  • Participant
    Level: Enlightened
    Posts: 68

    Nevermind. I just discovered the “Tab Scope” options on the right side.

  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39143

    Problem solved! Thanks, I would never have figured that out. Sorry that I brought a BuddyBoss issue to you instead of them – I just never knew to look in BuddyBoss settings because it doesn’t have the User Blog functionality.

    Perhaps it would be worth adding this instruction to the documentation for BuddyBlog, or even have a notification in its settings menu to instruct users to change that?

  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39139

    My reply just disappeared…

    I copied posts.php and replaced the text with some random characters. The profile page loads very differently. I did the same for entry-content.php and the profile loads fine but the posts lists is blank, so the overrides are working.

    The permissions in BuddyBlog weren’t set to Anyone, so that is why you got a 404. I have fixed this and restored the php files to their original contents.

    • This reply was modified 3 years ago by Nick.
  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39138

    I have posted some screenshots on the Timeline where you can see my BuddyBlog Settings. Everything else is stock as I just reset the WordPress installation – the only other relevant plugins activated are BuddyBoss Platform and BuddyBoss Platform Pro.

  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39134

    Also, I should say that I am reasonably technically capable, but it is generally safe to assume that I know nothing about WordPress. So, please provide specific steps that I can try rather than expect that I know what to do.

    As an alternative, I can also give you access to a staging site to look for yourself. But that would be a bit of a hassle to set up so I hope we can debug it from here.

    At the very least, you can visit this link to see what I am seeing. https://seeingtheforest.net/admin/post/

    The Post tab is created from BuddyBlog Pro and where the problem lies. You can see in the Timeline that the excerpts show up properly.

    • This reply was modified 3 years ago by Nick.
  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39133

    Time offset is fine – I created that post 8 hours ago. I created another just now and it has the same problems.

    “If you are using BuddyBoss child theme, then any change in the above file will reflect. Please try that. This entry is used on the profile/Posts tab.”

    Please try what?

    I can also confirm that the posts are showing up in the standard WP Posts dashboard view. Furthermore, If I edit the posts from there and manually add an excerpt, this doesn’t show either.

  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39129

    I have put it in the directory you confirmed and it still doesn’t work. I can confirm that it appears in the Theme Editor window, alongside functions.php, etc…

    I know it is a different mechanism, but in my timeline/newsfeed the post shows up appropriately saying

    admin posted a new post, Test
    7 hours, 8 minutes ago

    excerpt text

    Read more

    Like Comment Delete

    • This reply was modified 3 years ago by Nick.
  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39128

    I should also add that I just reset my website using the WP Reset plugin (I wanted to clean up lots of extraneous tables, post types etc…) and the problem persists.

  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39126

    Can you please confirm what the paths should be?

    child-theme/buddyblog/buddyboss/default/entry-content.php is a different path from the /plugins/ path you provided (missing the /templates/ folder, and has /buddyblog/ vs /buddyblog-pro/).

    Also, my existing /plugins/ path does not match what you described

    what you listed:
    wp-content/plugins/buddyblog-pro/templates/buddyboss/default/entry-content.php

    mine:
    wp-content/plugins/buddyblog-pro/templates/buddyblog/buddyboss/default/entry-content.php

    Anyway, I copied the entry-content.php file from where it was to the following path, so as to mirror it perfectly.

    wp-content/themes/buddyboss-theme-child/buddyblog-pro/templates/buddyblog/buddyboss/default/entry-content.php

    Nothing happened. Do I need to activate it somewhere?

    Thanks!

  • Participant
    Level: Enlightened
    Posts: 68
    Nick on in reply to: [Resolved] Change format of BuddyBlog Pro Post List #39120

    Not your fault! It is entirely possible that I overrode it… How would I restore it or reset everything to defaults?