BuddyDev

Search

[Resolved] BuddyPress Multi Network – troubleshooting set up

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #28637

    Hi,
    Thank you for the reply.

    The users are automatically added to the site by bbPress. Since you are using BuddyBoss platform, I will suggest contacting them and asking how to prevent it(In normal bbPress, there is an option under settings->Forums to turn it off).

    Only after that any redirect code will work. Please let me know once you are done with it and I will assist with the redirect.

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 25
    hangojango on #28640

    Thanks Brajesh,

    I will ask them but I’m not sure if they will be as responsive as you’ve been.

    I’m just wondering – if they don’t reply to me, could I pay for troubleshooting for you to look at the code? (https://buddydev.com/buddypress-troubleshooting-support/)

    I suspect you’d be the next-best person to take a look after BuddyBoss themselves.

  • Participant
    Level: Enlightened
    Posts: 25
    hangojango on #28641

    Actually, I don’t think we even have to wait to see if BuddyBoss will help me out. They don’t provide any support for the plugin (which is free), only their theme, which I’m not using.

    Could you please advise further re troubleshooting request. As you’ve already logged in to have a look, you may have an idea of what is entailed?

    Cheers.

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #28647

    Hi,
    Thank you.

    I had a look again and it seems they have removed the settings for this while keeping the auto add to site on.

    I can disable it using code(only a couple of lines), I will update the bp-custom.php and get back to you in 30 mins to 1 hour.

    If I am able to solve it and you opt for the Troubleshooting( 1 issue), It will be appreciated.

    Regards
    Brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #28652

    Hi,
    Can you please check if it s working or not?

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 25
    hangojango on #28666
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 25
    hangojango on #28667

    Hi again,

    If it’s too complicated to redirect non-members to the no-login page, we can just drop the redirection. The main issue is just to stop network members from logging into subsites where they are not members.

    So that would mean that if they can’t log in (because they are not members of the subsite, even if they are members on other sites in the network), then the login page simply wouldn’t let them in and they would stay looking at it after a failed attempt.

    Please let me know if that works. I have members using this subsite (I’ve put a message up to say we are troubleshooting today) so it would be good to know soon.

    Thanks.

  • Keymaster
    (BuddyDev Team)
    Posts: 19540
    Brajesh Singh on #28668

    Hi,
    It is not difficult. I actually made it this way.
    Before I modify it, Please help me understand this:-

    1. Do we allow logged out users to access the sub site(do not apply restrictions) and only apply restrictions if a user is logged in and not member of the current site?

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 25
    hangojango on #28669
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 25
    hangojango on #28670
    This reply has been marked as private.

The topic ‘ [Resolved] BuddyPress Multi Network – troubleshooting set up’ is closed to new replies.

This topic is: resolved