BuddyDev

Search

Member Type Pro not setting member types with Memberpress anymore after update


  • Participant
    Level: Initiated
    Posts: 18
    Philip Strothmann on #25236

    Dear @sbrajesh.

    after the latest update, Member Types Pro and Memberpress don’t work together anymore to properly set the member type?! Not sure if this is just an issue in my set up where I have multiple member type fields, but it used to work just fine and now it stopped working! Would be great if you could look into it 🙂

    Thanks so much in advance!

    Kind regards, Philip


  • Keymaster
    (BuddyDev Team)
    Posts: 12575
    Brajesh Singh on #25240

    Hi Phillip,
    I am sorry for the inconvenience.

    for the time being, Please revert back to the older version from here

    https://buddydev.com/plugins/buddypress-member-types-pro/#changelog

    Our team is looking at it and will have another update for memberpress compatibility in a day.

    Thank you
    Brajesh


  • Participant
    Level: Initiated
    Posts: 18
    Philip Strothmann on #25332

    Dear @sbrajesh,

    I solved the issue myself 🙂 It wasn’t with Member Types Pro, but traced back to a Memberpress configuration issue which I have now addressed 🙂

    Kind regards, Philip


  • Keymaster
    (BuddyDev Team)
    Posts: 12575
    Brajesh Singh on #25339

    Hi Phillip,
    Thank you for the update. I am glad you resolved it. Appreciate updating here.

    Regards
    Brajesh


  • Participant
    Level: Initiated
    Posts: 3
    SeattleGuy on #25672

    @fslci I have been struggling with the same problem for the last couple of weeks. Would you mind sharing what you changed with the Memberpress configuration to rectify this problem? Many thanks in advance!


  • Participant
    Level: Initiated
    Posts: 18
    Philip Strothmann on #25762

    Dear @sbrajesh,

    as also reported by @seattleguy, the issue is unfortunately still present. Not sure what changed – if anything – or whether I overlooked something in my testing, but it doesn’t work as it should. Member types are neither set for re-subscribed members, nor for new ones! Would be great if you could look into the issue again for us.

    Kind regards, Philip


  • Participant
    Level: Initiated
    Posts: 3
    SeattleGuy on #25774

    @fslci Curious if you are having the same problems we are. We offer a variety of different recurring memberships on our site (monthly, annual, etc.). We also offer “one month” only memberships where there is no recurring membership (set up as just a one time payment instead of a membership in Memberpress).

    After spending several hours examining and testing, we have found two critical problems:

    1) For the actual recurring memberships (monthly and annual), the Member Type Pro plugin does not set the correct member type. We’ve followed the instructions on how to trigger Member Type Pro to set the member type within each Memberpress “membership” but never works. Member Type Pro DOES set the correct member type for our “one month” only memberships each and every time one is purchased – again, just a one time payment instead of a recurring membership/payment.

    2) More concerning, we’re discovering that even when we manually set the member type for our recurring memberships, Member Type Pro “forgets” the member type after a few hours to a day.

    Similar to your problems?

    @sbrajesh appreciate all of your previous help and hope that you can look into this at your earliest.


  • Participant
    Level: Initiated
    Posts: 18
    Philip Strothmann on #25779

    Dear @seattleguy,

    we just have reoccurring annual subscriptions and for those it doesn’t work.

    I don’t think I’ve seen the second issue you reported, but I will monitor it!

    Kind regards, Philip


  • Participant
    Level: Initiated
    Posts: 3
    SeattleGuy on #25780

    @fslci Ah, got it. Thanks!


  • Keymaster
    (BuddyDev Team)
    Posts: 12575
    Brajesh Singh on #25794

    Hi Phillip, @seattleguy
    Thank you both of you.

    I regret to inform that we are unable to provide any quick update on this. The developer who worked on the integration is currently not available to update(due to his other commitments).

    I will be working on it after 29th and will provide an update.

    Thank you for the cooperation.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved
Subscribe