BuddyDev

Search

Replies

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #30102

    Dear Brajesh,

    so sorry, I should have doubled checked the version number because I checked for updates before I posted today! I didn’t think you would react so super quickly to get this fixed and thus thought the issue was related to Youzer. My bad, version 1.0.6 fixed the issue indeed, thanks you SO MUCH 🙂

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #30100

    Dear @sbrajesh,

    actually I’ve been on 1.0.6. for quite a while. I suspect then that the issue might be caused by Youzer? It’s a plugin that I use for buddypress and it comes with custom status formats to add functionality to status posts. Could you point me to where in the code of your plugin I could essentially add custom update types so it’s supported?

    That would be fantastic. Have a nice weekend.

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #30088

    Dear @sbrajesh,

    this issue seems to still be present. Whenever I delete a status update in a group etc, the notification stays and appears as a blank notification, instead of being cleared. That’s quite irritating for users and it would be fantastic if this could be addressed 🙂

    Thanks so much in advance.

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #26383

    Dear @sBrajesh,

    this is really disappointing, as it created a significant added value for the plugin. Also, given that Memberpress updates their plugin maybe 4-5 times a year, I don’t think your argument is entirely on point. The issue is more that the integration so far never really fully worked, so I feel that if you would actually make it work for good, it then also wouldn’t break anymore as the process you rely on, doesn’t change much in Memberpress itself. Did you ever reach out to the Memberpress guys? They might help you with the integration which could lead to a cross-promotion of both plugins!


    @Seattleguy
    : One work-around is to use the User Roles Addon from Memberpress, which can be linked to Subscriptions. Then use Member Type Pro’s option to associate member types with member roles and it should continue to work for setting member types in the first place. This is how I did it before the integration was launched. The downside is that it doesn’t work as smoothly when you have memberships expire etc. But it’s better than nothing!

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #25801

    Dear Brajesh,

    that’s unfortunate, but thanks for letting us know!

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #25779

    Dear @Seattleguy,

    we just have reoccurring annual subscriptions and for those it doesn’t work.

    I don’t think I’ve seen the second issue you reported, but I will monitor it!

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #25762

    Dear @sbrajesh,

    as also reported by @seattleguy, the issue is unfortunately still present. Not sure what changed – if anything – or whether I overlooked something in my testing, but it doesn’t work as it should. Member types are neither set for re-subscribed members, nor for new ones! Would be great if you could look into the issue again for us.

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #25332

    Dear @sbrajesh,

    I solved the issue myself 🙂 It wasn’t with Member Types Pro, but traced back to a Memberpress configuration issue which I have now addressed 🙂

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #23661

    Dear Brajesh,

    thanks for your quick reply 🙂 You mean we set a filter that the Profile Completion check only fires if the user would not be redirected to page XY? That could work.

    So in my case the issue is that when people are signing up via Memberpress (and do not use the free account option), the payment and account creation process stopped working since the last Memberpress update because it seems that they included some sort of change which caused the Memberpress redirects not to overrule the Profile Completion check, like they did before.

    Previously a user signed up via Memberpress, then got forwarded to a specific Thank You page and Member Type Pro set the member type based on the role assigned by Memberpress. Next time the user would login, the Profile Completion redirect would kick in. Unfortunately, now something has changed and thus the moment I click on “Submit” in the Memberpress registration form, an account is created, but no payment is processed and users end up being stuck at the buddypress profile page.

    That’s why I thought using a filter based on number of logins after account activation could solve the issue? But your approach of excluding the Thank You pages could also work, if you tell me how to set it up 🙂

    Kind regards, Philip

  • Participant
    Level: Enlightened
    Posts: 22
    Philip Strothmann on #22241

    Dear Brasjesh,

    just FYI: It works because I set the field to have “Free User” as the default value and selected the option to not allow users to change member type after registration for this field – which I disabled via CSS on the frontend. That way the value is set, even though the user never sees it on the frontend 🙂

    Have a nice weekend!

    Kind regards, Philip